<!doctype html>
<!--[if !IE]>
<html class="no-js non-ie" lang="en-US"
	prefix="og: https://ogp.me/ns#" > <![endif]-->
<!--[if IE 7 ]>
<html class="no-js ie7" lang="en-US"
	prefix="og: https://ogp.me/ns#" > <![endif]-->
<!--[if IE 8 ]>
<html class="no-js ie8" lang="en-US"
	prefix="og: https://ogp.me/ns#" > <![endif]-->
<!--[if IE 9 ]>
<html class="no-js ie9" lang="en-US"
	prefix="og: https://ogp.me/ns#" > <![endif]-->
<!--[if gt IE 9]><!-->
<html class="no-js" lang="en-US"
	prefix="og: https://ogp.me/ns#" > <!--<![endif]-->
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<meta name="theme-color" content="">
<meta property="fb:pages" content="424308691238741" />

<link rel="apple-touch-icon" sizes="57x57" href="https://linuxhostsupport.com/apple-icon-57x57.png">
<link rel="apple-touch-icon" sizes="60x60" href="https://linuxhostsupport.com/apple-icon-60x60.png">
<link rel="apple-touch-icon" sizes="72x72" href="https://linuxhostsupport.com/apple-icon-72x72.png">
<link rel="apple-touch-icon" sizes="76x76" href="https://linuxhostsupport.com/apple-icon-76x76.png">
<link rel="apple-touch-icon" sizes="114x114" href="https://linuxhostsupport.com/apple-icon-114x114.png">
<link rel="apple-touch-icon" sizes="120x120" href="https://linuxhostsupport.com/apple-icon-120x120.png">
<link rel="apple-touch-icon" sizes="144x144" href="https://linuxhostsupport.com/apple-icon-144x144.png">
<link rel="apple-touch-icon" sizes="152x152" href="https://linuxhostsupport.com/apple-icon-152x152.png">
<link rel="apple-touch-icon" sizes="180x180" href="https://linuxhostsupport.com/apple-icon-180x180.png">
<link rel="icon" type="image/png" sizes="192x192"  href="https://linuxhostsupport.com/android-icon-192x192.png">
<link rel="icon" type="image/png" sizes="32x32" href="https://linuxhostsupport.com/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="96x96" href="https://linuxhostsupport.com/favicon-96x96.png">
<link rel="icon" type="image/png" sizes="16x16" href="https://linuxhostsupport.com/favicon-16x16.png">
<link rel="manifest" href="https://linuxhostsupport.com/manifest.json">
<meta name="msapplication-TileColor" content="#ffffff">
<meta name="msapplication-TileImage" content="https://linuxhostsupport.com/ms-icon-144x144.png">
<meta name="theme-color" content="#ffffff">
<link href="https://fonts.googleapis.com/css?family=Open+Sans:300,400,400i,600,700" rel="stylesheet">
<link rel="profile" href="http://gmpg.org/xfn/11">
<title>How to Install Asterisk on Ubuntu 20.04</title>
<style type="text/css">			.heateorSssInstagramBackground{background:radial-gradient(circle at 30% 107%,#fdf497 0,#fdf497 5%,#fd5949 45%,#d6249f 60%,#285aeb 90%)}
											.heateor_sss_horizontal_sharing .heateorSssSharing,.heateor_sss_standard_follow_icons_container .heateorSssSharing{
							color: #fff;
						border-width: 0px;
			border-style: solid;
			border-color: transparent;
		}
				.heateor_sss_horizontal_sharing .heateorSssTCBackground{
			color:#666;
		}
				.heateor_sss_horizontal_sharing .heateorSssSharing:hover,.heateor_sss_standard_follow_icons_container .heateorSssSharing:hover{
						border-color: transparent;
		}
		.heateor_sss_vertical_sharing .heateorSssSharing,.heateor_sss_floating_follow_icons_container .heateorSssSharing{
							color: #fff;
						border-width: 0px;
			border-style: solid;
			border-color: transparent;
		}
				.heateor_sss_vertical_sharing .heateorSssTCBackground{
			color:#666;
		}
				.heateor_sss_vertical_sharing .heateorSssSharing:hover,.heateor_sss_floating_follow_icons_container .heateorSssSharing:hover{
						border-color: transparent;
		}
		
		@media screen and (max-width:783px) {.heateor_sss_vertical_sharing{display:none!important}}@media screen and (max-width:783px) {.heateor_sss_floating_follow_icons_container{display:none!important}}div.heateor_sss_mobile_footer{display:none;}@media screen and (max-width:783px){div.heateor_sss_bottom_sharing ul.heateor_sss_sharing_ul i.heateorSssTCBackground{background-color:white}div.heateor_sss_bottom_sharing{width:100%!important;left:0!important;}div.heateor_sss_bottom_sharing li{width:16.666666666667% !important;}div.heateor_sss_bottom_sharing .heateorSssSharing{width: 100% !important;}div.heateor_sss_bottom_sharing div.heateorSssTotalShareCount{font-size:1em!important;line-height:28px!important}div.heateor_sss_bottom_sharing div.heateorSssTotalShareText{font-size:.7em!important;line-height:0px!important}div.heateor_sss_mobile_footer{display:block;height:40px;}.heateor_sss_bottom_sharing{padding:0!important;display:block!important;width: auto!important;bottom:-2px!important;top: auto!important;}.heateor_sss_bottom_sharing .heateor_sss_square_count{line-height: inherit;}.heateor_sss_bottom_sharing .heateorSssSharingArrow{display:none;}.heateor_sss_bottom_sharing .heateorSssTCBackground{margin-right: 1.1em !important}}</style>
		<!-- All in One SEO 4.1.2.1 -->
		<meta name="description" content="Learn how to install Asterisk on Ubuntu 20.04 using this detailed tutorial. Step by step, here is how to set up Asterisk."/>
		<link rel="canonical" href="https://linuxhostsupport.com/blog/how-to-install-asterisk-on-ubuntu-20-04/" />
		<meta property="og:site_name" content="LinuxHostSupport" />
		<meta property="og:type" content="article" />
		<meta property="og:title" content="How to Install Asterisk on Ubuntu 20.04" />
		<meta property="og:description" content="Learn how to install Asterisk on Ubuntu 20.04 using this detailed tutorial. Step by step, here is how to set up Asterisk." />
		<meta property="og:url" content="https://linuxhostsupport.com/blog/how-to-install-asterisk-on-ubuntu-20-04/" />
		<meta property="og:image" content="https://linuxhostsupport.com/blog/wp-content/uploads/2021/05/how-to-install-asterisk-on-ubuntu-20.04.jpg" />
		<meta property="og:image:secure_url" content="https://linuxhostsupport.com/blog/wp-content/uploads/2021/05/how-to-install-asterisk-on-ubuntu-20.04.jpg" />
		<meta property="og:image:width" content="742" />
		<meta property="og:image:height" content="372" />
		<meta property="article:tag" content="tutorials" />
		<meta property="article:tag" content="asterisk" />
		<meta property="article:tag" content="linux" />
		<meta property="article:tag" content="ubuntu 20.04" />
		<meta property="article:published_time" content="2021-06-30T17:30:40Z" />
		<meta property="article:modified_time" content="2021-07-01T08:16:04Z" />
		<meta property="article:publisher" content="https://www.facebook.com/linuxhostsupport" />
		<meta name="twitter:card" content="summary_large_image" />
		<meta name="twitter:site" content="@lnxhostsupport" />
		<meta name="twitter:domain" content="linuxhostsupport.com" />
		<meta name="twitter:title" content="How to Install Asterisk on Ubuntu 20.04" />
		<meta name="twitter:description" content="Learn how to install Asterisk on Ubuntu 20.04 using this detailed tutorial. Step by step, here is how to set up Asterisk." />
		<meta name="twitter:image" content="https://linuxhostsupport.com/blog/wp-content/uploads/2021/05/how-to-install-asterisk-on-ubuntu-20.04.jpg" />
		<meta name="google" content="nositelinkssearchbox" />
		<script type="application/ld+json" class="aioseo-schema">
			{"@context":"https:\/\/schema.org","@graph":[{"@type":"WebSite","@id":"https:\/\/linuxhostsupport.com\/blog\/#website","url":"https:\/\/linuxhostsupport.com\/blog\/","name":"LinuxHostSupport","description":"Linux Tutorials and Guides","publisher":{"@id":"https:\/\/linuxhostsupport.com\/blog\/#organization"}},{"@type":"Organization","@id":"https:\/\/linuxhostsupport.com\/blog\/#organization","name":"LinuxHostSupport","url":"https:\/\/linuxhostsupport.com\/blog\/","sameAs":["https:\/\/www.facebook.com\/linuxhostsupport","https:\/\/twitter.com\/lnxhostsupport"]},{"@type":"BreadcrumbList","@id":"https:\/\/linuxhostsupport.com\/blog\/how-to-install-asterisk-on-ubuntu-20-04\/#breadcrumblist","itemListElement":[{"@type":"ListItem","@id":"https:\/\/linuxhostsupport.com\/blog\/#listItem","position":"1","item":{"@type":"WebPage","@id":"https:\/\/linuxhostsupport.com\/blog\/","name":"Home","description":"The official LinuxHostSupport.com blog with Linux tutorials, guides and tips and tricks.","url":"https:\/\/linuxhostsupport.com\/blog\/"},"nextItem":"https:\/\/linuxhostsupport.com\/blog\/how-to-install-asterisk-on-ubuntu-20-04\/#listItem"},{"@type":"ListItem","@id":"https:\/\/linuxhostsupport.com\/blog\/how-to-install-asterisk-on-ubuntu-20-04\/#listItem","position":"2","item":{"@type":"WebPage","@id":"https:\/\/linuxhostsupport.com\/blog\/how-to-install-asterisk-on-ubuntu-20-04\/","name":"How to Install Asterisk on Ubuntu 20.04","description":"Learn how to install Asterisk on Ubuntu 20.04 using this detailed tutorial. Step by step, here is how to set up Asterisk.","url":"https:\/\/linuxhostsupport.com\/blog\/how-to-install-asterisk-on-ubuntu-20-04\/"},"previousItem":"https:\/\/linuxhostsupport.com\/blog\/#listItem"}]},{"@type":"Person","@id":"https:\/\/linuxhostsupport.com\/blog\/author\/r0s3admin\/#author","url":"https:\/\/linuxhostsupport.com\/blog\/author\/r0s3admin\/","name":"admin","image":{"@type":"ImageObject","@id":"https:\/\/linuxhostsupport.com\/blog\/how-to-install-asterisk-on-ubuntu-20-04\/#authorImage","url":"https:\/\/secure.gravatar.com\/avatar\/03ae9b148caf9a61c873e2b8c354cb52?s=96&d=mm&r=g","width":"96","height":"96","caption":"admin"},"sameAs":["https:\/\/www.facebook.com\/linuxhostsupport","https:\/\/twitter.com\/lnxhostsupport"]},{"@type":"WebPage","@id":"https:\/\/linuxhostsupport.com\/blog\/how-to-install-asterisk-on-ubuntu-20-04\/#webpage","url":"https:\/\/linuxhostsupport.com\/blog\/how-to-install-asterisk-on-ubuntu-20-04\/","name":"How to Install Asterisk on Ubuntu 20.04","description":"Learn how to install Asterisk on Ubuntu 20.04 using this detailed tutorial. Step by step, here is how to set up Asterisk.","inLanguage":"en-US","isPartOf":{"@id":"https:\/\/linuxhostsupport.com\/blog\/#website"},"breadcrumb":{"@id":"https:\/\/linuxhostsupport.com\/blog\/how-to-install-asterisk-on-ubuntu-20-04\/#breadcrumblist"},"author":"https:\/\/linuxhostsupport.com\/blog\/how-to-install-asterisk-on-ubuntu-20-04\/#author","creator":"https:\/\/linuxhostsupport.com\/blog\/how-to-install-asterisk-on-ubuntu-20-04\/#author","image":{"@type":"ImageObject","@id":"https:\/\/linuxhostsupport.com\/blog\/#mainImage","url":"https:\/\/linuxhostsupport.com\/blog\/wp-content\/uploads\/2021\/05\/how-to-install-asterisk-on-ubuntu-20.04.jpg","width":"742","height":"372"},"primaryImageOfPage":{"@id":"https:\/\/linuxhostsupport.com\/blog\/how-to-install-asterisk-on-ubuntu-20-04\/#mainImage"},"datePublished":"2021-06-30T17:30:40-05:00","dateModified":"2021-07-01T08:16:04-05:00"},{"@type":"Article","@id":"https:\/\/linuxhostsupport.com\/blog\/how-to-install-asterisk-on-ubuntu-20-04\/#article","name":"How to Install Asterisk on Ubuntu 20.04","description":"Learn how to install Asterisk on Ubuntu 20.04 using this detailed tutorial. Step by step, here is how to set up Asterisk.","headline":"How to Install Asterisk on Ubuntu 20.04","author":{"@id":"https:\/\/linuxhostsupport.com\/blog\/author\/r0s3admin\/#author"},"publisher":{"@id":"https:\/\/linuxhostsupport.com\/blog\/#organization"},"datePublished":"2021-06-30T17:30:40-05:00","dateModified":"2021-07-01T08:16:04-05:00","articleSection":"Tutorials, asterisk, linux, ubuntu 20.04","mainEntityOfPage":{"@id":"https:\/\/linuxhostsupport.com\/blog\/how-to-install-asterisk-on-ubuntu-20-04\/#webpage"},"isPartOf":{"@id":"https:\/\/linuxhostsupport.com\/blog\/how-to-install-asterisk-on-ubuntu-20-04\/#webpage"},"image":{"@type":"ImageObject","@id":"https:\/\/linuxhostsupport.com\/blog\/#articleImage","url":"https:\/\/linuxhostsupport.com\/blog\/wp-content\/uploads\/2021\/05\/how-to-install-asterisk-on-ubuntu-20.04.jpg","width":"742","height":"372"}}]}
		</script>
		<!-- All in One SEO -->

<link rel="amphtml" href="https://linuxhostsupport.com/blog/how-to-install-asterisk-on-ubuntu-20-04/amp/" /><meta name="generator" content="AMP for WP 1.0.77.9"/><link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="LinuxHostSupport &raquo; Feed" href="https://linuxhostsupport.com/blog/feed/" />
<link rel="alternate" type="application/rss+xml" title="LinuxHostSupport &raquo; Comments Feed" href="https://linuxhostsupport.com/blog/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="LinuxHostSupport &raquo; How to Install Asterisk on Ubuntu 20.04 Comments Feed" href="https://linuxhostsupport.com/blog/how-to-install-asterisk-on-ubuntu-20-04/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/linuxhostsupport.com\/blog\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<!-- linuxhostsupport.com/blog is managing ads with Advanced Ads 1.25.1 --><script>
			advanced_ads_ready=function(){var e,t=[],n="object"==typeof document&&document,d=n&&n.documentElement.doScroll,o="DOMContentLoaded",a=n&&(d?/^loaded|^c/:/^loaded|^i|^c/).test(n.readyState);return!a&&n&&(e=function(){for(n.removeEventListener(o,e),window.removeEventListener("load",e),a=1;e=t.shift();)e()},n.addEventListener(o,e),window.addEventListener("load",e)),function(e){a?setTimeout(e,0):t.push(e)}}();		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://linuxhostsupport.com/blog/wp-includes/css/dist/block-library/style.min.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='sparkling-bootstrap-css'  href='https://linuxhostsupport.com/blog/wp-content/themes/lhs/inc/css/bootstrap.min.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='sparkling-icons-css'  href='https://linuxhostsupport.com/blog/wp-content/themes/lhs/inc/css/font-awesome.min.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='sparkling-fonts-css'  href='//fonts.googleapis.com/css?family=Open+Sans%3A400italic%2C400%2C600%2C700%7CRoboto+Slab%3A400%2C300%2C700&#038;ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='sparkling-style-css'  href='https://linuxhostsupport.com/blog/wp-content/themes/lhs/style.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='heateor_sss_frontend_css-css'  href='https://linuxhostsupport.com/blog/wp-content/plugins/sassy-social-share/public/css/sassy-social-share-public.css?ver=3.3.21' type='text/css' media='all' />
<link rel='stylesheet' id='heateor_sss_sharing_default_svg-css'  href='https://linuxhostsupport.com/blog/wp-content/plugins/sassy-social-share/admin/css/sassy-social-share-svg.css?ver=3.3.21' type='text/css' media='all' />
<script type='text/javascript' src='https://linuxhostsupport.com/blog/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://linuxhostsupport.com/blog/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://linuxhostsupport.com/blog/wp-content/themes/lhs/inc/js/modernizr.min.js?ver=5.7.2' id='sparkling-modernizr-js'></script>
<script type='text/javascript' src='https://linuxhostsupport.com/blog/wp-content/themes/lhs/inc/js/bootstrap.min.js?ver=5.7.2' id='sparkling-bootstrapjs-js'></script>
<link rel="https://api.w.org/" href="https://linuxhostsupport.com/blog/wp-json/" /><link rel="alternate" type="application/json" href="https://linuxhostsupport.com/blog/wp-json/wp/v2/posts/1429" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://linuxhostsupport.com/blog/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://linuxhostsupport.com/blog/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7.2" />
<link rel='shortlink' href='https://linuxhostsupport.com/blog/?p=1429' />
<link rel="alternate" type="application/json+oembed" href="https://linuxhostsupport.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flinuxhostsupport.com%2Fblog%2Fhow-to-install-asterisk-on-ubuntu-20-04%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://linuxhostsupport.com/blog/wp-json/oembed/1.0/embed?url=https%3A%2F%2Flinuxhostsupport.com%2Fblog%2Fhow-to-install-asterisk-on-ubuntu-20-04%2F&#038;format=xml" />
<style type="text/css"></style><style type="text/css">.broken_link, a.broken_link {
	text-decoration: line-through;
}</style>		<style type="text/css" id="wp-custom-css">
			/*
You can add your own CSS here.

Click the help icon above to learn more.
*/

pre {	
    background: rgba(194, 189, 189, 0.3) none repeat scroll 0 0;
}		</style>
		
</head>

<body class="post-template-default single single-post postid-1429 single-format-standard aa-prefix-linux-">
<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-TBQFNCW"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
<a class="sr-only sr-only-focusable" href="#content">Skip to main content</a>
<div id="page" class="hfeed site">

	<header id="masthead" class="site-header" role="banner">
		<nav class="navbar navbar-default navbar-custom navbar-fixed-top" role="navigation">
        <div class="container">
            <div class="navbar-header page-scroll">
                <button type="button" class="navbar-toggle" data-toggle="collapse" data-target="#bs-example-navbar-collapse-1">
                    <span class="sr-only">Toggle navigation</span>
                    Menu <i class="fa fa-bars"></i>
                </button>
                <a class="navbar-brand" href="https://linuxhostsupport.com/"><svg class="logo" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 245 30">
  <path d="M43.493 19.83H54.23v-3.265h-6.835V2.642h-3.902zm16.798 0V7.36h-3.87v12.47zM58.36 1.927c-.633.012-1.133.198-1.498.56-.366.364-.546.83-.543 1.403-.01.55.17 1.007.54 1.372.36.364.85.553 1.47.567.64-.02 1.15-.21 1.52-.57.37-.37.56-.82.57-1.37-.02-.58-.21-1.04-.58-1.41-.37-.36-.86-.55-1.49-.56zm5.035 17.9h3.876v-7.19c0-.182.02-.36.04-.532.03-.173.06-.32.12-.437.13-.374.35-.706.68-.995.33-.29.76-.444 1.29-.46.7.013 1.2.263 1.51.75.31.487.46 1.138.46 1.954v6.91h3.88V12.43c-.03-1.83-.45-3.18-1.27-4.053-.83-.874-1.89-1.307-3.18-1.3-1.03.032-1.87.265-2.51.697-.64.432-1.09.863-1.34 1.29h-.08l-.18-1.707H63.3c.03.548.05 1.154.07 1.816.02.664.03 1.384.03 2.16zM90.085 7.36h-3.902v7.42c.002.155-.007.305-.025.45-.014.145-.05.276-.1.392-.12.324-.346.625-.658.905-.31.28-.738.428-1.277.446-.665-.008-1.16-.266-1.473-.775-.31-.507-.46-1.218-.46-2.132V7.36h-3.9v7.318c.027 1.91.438 3.298 1.245 4.16.808.862 1.856 1.286 3.138 1.272 1.12-.038 1.984-.282 2.614-.733.63-.452 1.056-.888 1.29-1.307h.077l.177 1.76h3.37c-.02-.523-.05-1.117-.07-1.783-.01-.666-.03-1.406-.03-2.22zm1.71 0l4.13 6.12-4.23 6.35h4.256l1.18-2.245c.16-.304.31-.613.47-.924.16-.31.32-.63.47-.96h.08c.15.32.31.64.47.95.16.31.33.62.51.94l1.25 2.24h4.39l-4.16-6.52 4.11-5.94h-4.21l-1.1 2.01c-.17.32-.32.63-.49.95-.16.32-.31.65-.48.97h-.05c-.17-.3-.33-.6-.5-.91-.17-.32-.35-.63-.52-.95l-1.23-2.07zm14.753-4.718V19.83h3.902v-7.192h6.4v7.19h3.873V2.643h-3.875v6.605h-6.404V2.642zm23.396 4.437c-2.03.02-3.64.62-4.83 1.79s-1.8 2.77-1.826 4.81c.04 2.03.66 3.6 1.858 4.72 1.205 1.11 2.735 1.68 4.598 1.7 1.735 0 3.25-.53 4.54-1.62 1.297-1.09 1.977-2.77 2.04-5.04-.028-1.91-.61-3.44-1.75-4.6-1.14-1.16-2.684-1.75-4.618-1.78zm-.102 2.75c.875.04 1.507.43 1.898 1.17.392.74.585 1.6.578 2.57-.01 1.13-.234 2.04-.673 2.71-.44.67-1.04 1.01-1.8 1.03-.833-.03-1.464-.38-1.898-1.07-.432-.7-.65-1.59-.653-2.68-.01-.96.183-1.82.578-2.57.393-.75 1.05-1.15 1.97-1.19zm8.14 9.38c.48.26 1.065.47 1.758.62.692.15 1.45.24 2.272.24 1.786-.03 3.134-.41 4.04-1.15.908-.74 1.363-1.71 1.365-2.89-.004-.92-.276-1.68-.816-2.31-.54-.63-1.4-1.14-2.57-1.55-.75-.26-1.28-.49-1.58-.69-.3-.21-.44-.45-.43-.74 0-.32.13-.57.39-.75.26-.18.62-.27 1.1-.27.55.01 1.06.09 1.54.24s.87.31 1.16.47l.69-2.68c-.39-.197-.89-.364-1.5-.5-.61-.137-1.28-.208-2.02-.213-1.56.025-2.79.415-3.69 1.17-.9.755-1.36 1.725-1.37 2.91-.02.75.24 1.45.8 2.105.56.65 1.47 1.2 2.75 1.64.72.23 1.21.45 1.47.652.26.212.39.47.377.772.01.32-.12.58-.39.76-.26.19-.686.29-1.266.29-.59-.01-1.2-.115-1.823-.31-.624-.19-1.127-.4-1.51-.63zM150.29 4.65v2.71h-1.66v2.856h1.656v5.1c0 .878.09 1.622.268 2.23.184.61.446 1.1.808 1.467.31.323.715.58 1.218.775.506.192 1.066.292 1.696.297.553-.002 1.048-.032 1.488-.09.44-.06.786-.14 1.04-.242l-.02-2.933c-.135.027-.305.05-.496.07-.19.02-.405.03-.653.032-.574.003-.977-.175-1.204-.532-.22-.357-.33-.91-.32-1.66v-4.514h2.79V7.36h-2.77V3.79z" class="linux-host"/>
  <path d="M158.888 18.988c.48.313 1.12.572 1.916.778.793.205 1.615.31 2.465.318 2.02-.04 3.53-.533 4.52-1.48.99-.944 1.49-2.1 1.49-3.467 0-1.244-.37-2.26-1.11-3.05-.74-.787-1.83-1.453-3.29-1.998-1.19-.44-2.05-.91-2.6-1.4-.55-.49-.83-1.14-.82-1.91-.02-.62.23-1.2.73-1.73s1.34-.81 2.49-.85c.78.01 1.45.11 2 .29s.98.35 1.26.52l.61-1.81c-.38-.22-.89-.42-1.53-.58-.64-.17-1.4-.25-2.28-.26-1.69.02-3.04.47-4.03 1.33-1 .85-1.51 1.97-1.53 3.33.01 1.21.42 2.2 1.22 2.98.79.78 1.9 1.42 3.32 1.9 1.15.43 1.98.91 2.49 1.44.51.52.76 1.18.75 1.97-.01.88-.33 1.583-.95 2.12-.62.522-1.51.8-2.65.81-.77-.01-1.5-.12-2.19-.336-.69-.214-1.29-.478-1.79-.79zm23.67-11.5h-2.245v7.573c0 .21-.018.41-.054.61-.04.2-.09.38-.15.55-.21.52-.57.99-1.07 1.4-.51.41-1.14.63-1.89.65-1.01-.01-1.72-.37-2.14-1.08-.43-.7-.63-1.65-.62-2.84V7.49h-2.25v7.217c.05 2.12.52 3.564 1.4 4.328.88.765 1.82 1.123 2.85 1.078 1.09-.03 1.97-.29 2.64-.77.66-.484 1.15-.99 1.44-1.52h.05l.12 2.013h1.99c-.07-.97-.11-2.09-.11-3.366zm3.717 17.39h2.218v-6.706h.05c.375.616.9 1.092 1.565 1.428.66.336 1.41.506 2.232.51 1.502 0 2.805-.55 3.896-1.65 1.09-1.103 1.657-2.763 1.714-4.98-.035-1.9-.53-3.416-1.495-4.543-.97-1.126-2.21-1.704-3.733-1.73-1.006.005-1.877.217-2.606.634-.73.42-1.325 1.01-1.786 1.77h-.05l-.105-2.12h-2.02c.03.59.05 1.21.072 1.87.02.66.028 1.38.028 2.17zm2.218-12.19c0-.153.015-.31.043-.468.028-.157.064-.307.106-.45.234-.85.66-1.525 1.282-2.02.617-.496 1.318-.748 2.104-.758 1.19.036 2.097.492 2.72 1.367.624.87.942 1.94.942 3.22-.007 1.43-.34 2.58-.984 3.44-.652.86-1.573 1.3-2.763 1.32-.822-.02-1.53-.26-2.132-.73-.6-.48-1.02-1.11-1.24-1.9-.02-.14-.04-.29-.07-.44-.02-.16-.02-.31-.02-.48zm12.27 12.19h2.218v-6.706h.05c.38.616.91 1.092 1.57 1.428.67.336 1.41.506 2.24.51 1.51 0 2.81-.55 3.9-1.65 1.09-1.103 1.66-2.763 1.72-4.98-.03-1.9-.53-3.416-1.49-4.543-.97-1.126-2.21-1.704-3.73-1.73-1.01.005-1.87.217-2.6.634-.73.42-1.32 1.01-1.78 1.77h-.05l-.1-2.12h-2.01c.03.59.05 1.21.07 1.87.03.66.03 1.38.04 2.17zm2.218-12.19c0-.153.02-.31.05-.468.03-.157.07-.307.11-.45.24-.85.66-1.525 1.28-2.02.62-.496 1.32-.748 2.11-.758 1.19.036 2.1.492 2.72 1.367.63.87.95 1.94.95 3.22 0 1.43-.34 2.58-.98 3.44-.65.86-1.57 1.3-2.76 1.32-.82-.02-1.53-.26-2.13-.73-.6-.48-1.02-1.11-1.23-1.9-.02-.14-.05-.29-.07-.44-.02-.16-.03-.31-.03-.48zm17.51-5.48c-1.75.013-3.2.59-4.34 1.727-1.14 1.136-1.74 2.745-1.78 4.825.04 1.972.61 3.517 1.71 4.638 1.1 1.126 2.51 1.693 4.21 1.714 1.57.014 2.96-.51 4.2-1.565 1.24-1.056 1.89-2.713 1.96-4.987-.03-1.913-.57-3.443-1.64-4.59-1.07-1.14-2.5-1.73-4.3-1.757zm-.05 1.682c1.32.066 2.26.595 2.85 1.586.58.992.87 2.044.86 3.157-.02 1.416-.37 2.562-1.07 3.44-.68.87-1.58 1.323-2.67 1.352-1.11-.03-2.01-.482-2.69-1.36-.68-.88-1.03-2.005-1.05-3.386 0-1.23.3-2.32.91-3.28.62-.97 1.58-1.47 2.9-1.53zm8.82 10.94h2.22v-6.58c0-.19.02-.375.04-.552.02-.175.05-.34.07-.493.17-.857.51-1.547 1.03-2.072.53-.524 1.19-.795 1.99-.81.15 0 .29.007.41.02.12.012.24.03.36.056V7.28c-.1-.025-.2-.045-.3-.057-.1-.014-.21-.02-.33-.02-.76.01-1.45.253-2.06.73-.61.478-1.06 1.136-1.35 1.974h-.1l-.07-2.424h-1.97c.04.572.07 1.176.08 1.81.02.636.02 1.316.02 2.04zm8.83-15.3v2.957h-1.91v1.71h1.92v6.73c0 .73.06 1.363.2 1.904.14.54.36.98.68 1.31.27.31.61.54 1.02.71.41.16.88.24 1.4.24.44 0 .82-.03 1.16-.08.33-.05.61-.13.83-.22l-.1-1.68c-.14.04-.32.08-.54.11-.21.03-.47.05-.76.05-.61 0-1.05-.21-1.31-.62-.25-.41-.38-1-.37-1.77V9.2h3.22V7.49h-3.21V3.944z" class="support"/>
  <path d="M0 1.047V23.35h6.195v6.293l7.87-6.294h18.15V1.04zm2.478 2.478h27.258V20.87H13.193l-4.52 3.616V20.87H2.478z" class="support"/>
  <path d="M10.176 8.018L8.333 9.86l3.565 3.565-3.565 3.564 1.843 1.84 4.485-4.49.89-.92-.88-.92zm6.127 7.97v2.563h7.69v-2.56z" class="support"/>
</svg>
</a>
            </div>
            <div class="collapse navbar-collapse" id="bs-example-navbar-collapse-1">
                <ul class="nav navbar-nav navbar-right">
                  <li class="dropdown">
                    <a href="https://linuxhostsupport.com" class="dropdown-toggle" data-toggle="dropdown" role="button" aria-haspopup="true" aria-expanded="false">Services <span class="caret"></span></a>
                    <ul class="dropdown-menu">
                      <li><a href="https://linuxhostsupport.com/monthly-server-management.html">Monthly Server Management</a></li>
                      <li><a href="https://linuxhostsupport.com/per-incident-support.html">Per Incident Support</a></li>
                      <li><a href="https://linuxhostsupport.com/outsourced-hosting-support.html">Outsourced Hosting Support</a></li>
					  <li><a href="https://linuxhostsupport.com/other-management-and-support-services.html">Other Management & Support Services</a></li>
                    </ul>
                  </li>
                    <li><a href="https://linuxhostsupport.com/support.html">Support</a></li>
                    <li><a href="https://linuxhostsupport.com/about.html">About</a></li>
                    <li><a href="https://linuxhostsupport.com/contact.html">Contact</a></li>
                    <li><a href="https://linuxhostsupport.com/blog/">Blog</a></li>
                    <li><a href="https://my.linuxhostsupport.com/index.php?/clientarea/">Login</a></li>
                </ul>
            </div>
        </div>
		</nav><!-- .site-navigation -->
	</header><!-- #masthead -->

	<div id="content" class="site-content">

		<div class="top-section">
								</div>

		<div class="container main-content-area">
            			<div class="row side-pull-left">
				<div class="main-content-inner col-sm-12 col-md-8">

	<div id="primary" class="content-area">
		<main id="main" class="site-main" role="main">

		
<article id="post-1429" class="post-1429 post type-post status-publish format-standard has-post-thumbnail hentry category-tutorials tag-asterisk tag-linux tag-ubuntu-20-04">
	<img width="742" height="372" src="https://linuxhostsupport.com/blog/wp-content/uploads/2021/05/how-to-install-asterisk-on-ubuntu-20.04.jpg" class="single-featured wp-post-image" alt="how to install asterisk on ubuntu 20.04" loading="lazy" srcset="https://linuxhostsupport.com/blog/wp-content/uploads/2021/05/how-to-install-asterisk-on-ubuntu-20.04.jpg 742w, https://linuxhostsupport.com/blog/wp-content/uploads/2021/05/how-to-install-asterisk-on-ubuntu-20.04-300x150.jpg 300w" sizes="(max-width: 742px) 100vw, 742px" />	<div class="post-inner-content">
		<header class="entry-header page-header">

			<h1 class="entry-title ">How to Install Asterisk on Ubuntu 20.04</h1>

			<div class="entry-meta">
				<span class="posted-on"><i class="fa fa-calendar"></i> <a href="https://linuxhostsupport.com/blog/how-to-install-asterisk-on-ubuntu-20-04/" rel="bookmark"><time class="entry-date published" datetime="2021-06-30T12:30:40-05:00">June 30, 2021</time><time class="updated" datetime="2021-07-01T03:16:04-05:00">July 1, 2021</time></a></span>
								<span class="cat-links"><i class="fa fa-folder-open-o"></i>
					 <a href="https://linuxhostsupport.com/blog/category/tutorials/" rel="category tag">Tutorials</a>				</span>
								
			</div><!-- .entry-meta -->
		</header><!-- .entry-header -->

		<div class="entry-content">
			<div class='heateorSssClear'></div><div  class='heateor_sss_sharing_container heateor_sss_horizontal_sharing' heateor-sss-data-href='https://linuxhostsupport.com/blog/how-to-install-asterisk-on-ubuntu-20-04/'><div class='heateor_sss_sharing_title' style="font-weight:bold" >Spread the love</div><ul class="heateor_sss_sharing_ul"><li class="heateorSssSharingRound"><i style="width:35px;height:35px;border-radius:999px;" alt="Facebook" Title="Facebook" class="heateorSssSharing heateorSssFacebookBackground" onclick='heateorSssPopup("https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Flinuxhostsupport.com%2Fblog%2Fhow-to-install-asterisk-on-ubuntu-20-04%2F")'><ss style="display:block;border-radius:999px;" class="heateorSssSharingSvg heateorSssFacebookSvg"></ss></i></li><li class="heateorSssSharingRound"><i style="width:35px;height:35px;border-radius:999px;" alt="Twitter" Title="Twitter" class="heateorSssSharing heateorSssTwitterBackground" onclick='heateorSssPopup("http://twitter.com/intent/tweet?text=How%20to%20Install%20Asterisk%20on%20Ubuntu%2020.04&url=https%3A%2F%2Flinuxhostsupport.com%2Fblog%2Fhow-to-install-asterisk-on-ubuntu-20-04%2F")'><ss style="display:block;border-radius:999px;" class="heateorSssSharingSvg heateorSssTwitterSvg"></ss></i></li><li class="heateorSssSharingRound"><i style="width:35px;height:35px;border-radius:999px;" alt="Linkedin" Title="Linkedin" class="heateorSssSharing heateorSssLinkedinBackground" onclick='heateorSssPopup("http://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Flinuxhostsupport.com%2Fblog%2Fhow-to-install-asterisk-on-ubuntu-20-04%2F&title=How%20to%20Install%20Asterisk%20on%20Ubuntu%2020.04")'><ss style="display:block;border-radius:999px;" class="heateorSssSharingSvg heateorSssLinkedinSvg"></ss></i></li><li class="heateorSssSharingRound"><i style="width:35px;height:35px;border-radius:999px;" alt="Pinterest" Title="Pinterest" class="heateorSssSharing heateorSssPinterestBackground" onclick="javascript:void( (function() {var e=document.createElement('script' );e.setAttribute('type','text/javascript' );e.setAttribute('charset','UTF-8' );e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);document.body.appendChild(e)})());"><ss style="display:block;border-radius:999px;" class="heateorSssSharingSvg heateorSssPinterestSvg"></ss></i></li><li class="heateorSssSharingRound"><i style="width:35px;height:35px;border-radius:999px;" alt="Reddit" Title="Reddit" class="heateorSssSharing heateorSssRedditBackground" onclick='heateorSssPopup("http://reddit.com/submit?url=https%3A%2F%2Flinuxhostsupport.com%2Fblog%2Fhow-to-install-asterisk-on-ubuntu-20-04%2F&title=How%20to%20Install%20Asterisk%20on%20Ubuntu%2020.04")'><ss style="display:block;border-radius:999px;" class="heateorSssSharingSvg heateorSssRedditSvg"></ss></i></li><li class="heateorSssSharingRound"><i style="width:35px;height:35px;border-radius:999px;" title="More" alt="More" class="heateorSssSharing heateorSssMoreBackground" onclick="heateorSssMoreSharingPopup(this, 'https://linuxhostsupport.com/blog/how-to-install-asterisk-on-ubuntu-20-04/', 'How%20to%20Install%20Asterisk%20on%20Ubuntu%2020.04', '' )" ><ss style="display:block" class="heateorSssSharingSvg heateorSssMoreSvg"></ss></i></li></ul><div class="heateorSssClear"></div></div><div class='heateorSssClear'></div>
<div class="linux-before-1st-paragraph" style="margin-left: auto; margin-right: auto; text-align: center; margin-top: 15px; margin-bottom: 15px; " id="linux-306668933"><a href="https://www.rosehosting.com/managed-vps-hosting.html"><img loading="lazy" src="https://linuxhostsupport.com/blog/wp-content/uploads/2020/12/5825194091162950216.jpg" alt=""  srcset="https://linuxhostsupport.com/blog/wp-content/uploads/2020/12/5825194091162950216.jpg 728w, https://linuxhostsupport.com/blog/wp-content/uploads/2020/12/5825194091162950216-300x37.jpg 300w" sizes="(max-width: 728px) 100vw, 728px" width="728" height="90"  style="display: inline-block;" /></a></div><p>Asterisk is an open-source framework used for building communications applications including VoIP gateways, and conference servers. It is used by small businesses, enterprises, call centers, and governments worldwide. Asterisk uses a VoIP protocol that allows you to make a call using the TCP/IP without any cost. It provides very useful features including, voicemail, call recording, automatic call, music on hold, messaging, and more.<img loading="lazy" class=" wp-image-1435 alignright" src="https://linuxhostsupport.com/blog/wp-content/uploads/2021/05/install-asterisk-on-ubuntu-20.04.png" alt="install asterisk on ubuntu 20.04" width="142" height="142" srcset="https://linuxhostsupport.com/blog/wp-content/uploads/2021/05/install-asterisk-on-ubuntu-20.04.png 200w, https://linuxhostsupport.com/blog/wp-content/uploads/2021/05/install-asterisk-on-ubuntu-20.04-150x150.png 150w, https://linuxhostsupport.com/blog/wp-content/uploads/2021/05/install-asterisk-on-ubuntu-20.04-60x60.png 60w" sizes="(max-width: 142px) 100vw, 142px" /></p>



<p>Asterisk can run on multiple operating systems, although it was originally created for Linux. Today, NetBSD, macOS, and Solaris users, among others, can install and use the Asterisk software with ease.<span id="more-1429"></span></p>





<p>In this guide, we will show you how to install and configure Asterisk on Ubuntu 20.04.</p>



<h2 id="h-prerequisites">Prerequisites</h2>



<ul>
<li>An Ubuntu 20.04 VPS (we’ll be using our SSD 2 VPS plan)</li>
<li>Access to the root user account (or access to an admin account with root privileges)</li>
</ul>



<h2 id="h-log-in-to-the-server-update-the-server-os-packages">Log in to the Server &amp; Update the Server OS Packages</h2>



<p>First, log in to your Ubuntu 20.04 server via SSH as the root user:</p>



<pre class="wp-block-preformatted">ssh root@IP_Address -p Port_number</pre>



<p>You will need to replace &#8216;IP_Address&#8217; and &#8216;Port_number&#8217; with your server’s respective IP address and SSH port number. Additionally, replace &#8216;root&#8217; with the username of the admin account if necessary.</p>



<p>Before starting, you have to make sure that all Ubuntu OS packages installed on the server are up to date. You can do this by running the following commands:</p>



<pre class="wp-block-preformatted">apt-get update -y
apt-get upgrade -y</pre>



<h2 id="h-install-required-dependencies">Install Required Dependencies</h2>



<p>Before starting, you will need to install some dependencies required to build the Asterisk server. You can install all of them using the following command:</p>



<pre class="wp-block-preformatted">apt-get install build-essential git autoconf wget subversion pkg-config libjansson-dev libxml2-dev uuid-dev libsqlite3-dev libtool -y</pre>



<p>Once all the packages are installed, you will need to install DAHDI to communicate Asterisk with analog and digital telephones.</p>



<p>First, download the latest version of DAHDI to the /opt directory:</p>



<pre class="wp-block-preformatted">cd /opt
git clone -b next git://git.asterisk.org/dahdi/linux dahdi-linux</pre>



<p>Next, change the directory to the downloaded directory and compile it using the following command:</p>



<pre class="wp-block-preformatted">cd dahdi-linux
make
make install</pre>



<p>Next, download the DAHDI tools with the following command:</p>



<pre class="wp-block-preformatted">cd /opt
git clone -b next git://git.asterisk.org/dahdi/tools dahdi-tools</pre>



<p>Once the download is completed, configure and install it with the following command:</p>



<pre class="wp-block-preformatted">cd dahdi-tools
autoreconf -i
./configure
make install
make install-config
dahdi_genconf modules</pre>



<p>Next, download the LibPRI to communicate Asterisk with ISDN connections.</p>



<pre class="wp-block-preformatted">git clone https://gerrit.asterisk.org/libpri libpri
cd libpri</pre>



<p>Next, install it using the following command:</p>



<pre class="wp-block-preformatted">make
make install</pre>



<p>Once all the necessary tools are installed, you can proceed to install Asterisk.</p>



<h2 id="h-install-asterisk">Install Asterisk</h2>



<p>By default, the Asterisk package is not included in the Ubuntu 20.04 default repository. So you will need to download and compile it from the source. You can download it from the Git Hub using the following command:</p>



<pre class="wp-block-preformatted">git clone -b 18 https://gerrit.asterisk.org/asterisk asterisk-18</pre>



<p>Once the download is completed, change the directory to the downloaded directory and install required dependencies with the following command:</p>



<pre class="wp-block-preformatted">cd asterisk-18/
contrib/scripts/get_mp3_source.sh
contrib/scripts/install_prereq install</pre>



<p>Next, configure the Asterisk with the following command:</p>



<pre class="wp-block-preformatted">./configure</pre>



<p>You should get the following output:</p>



<pre class="wp-block-preformatted">configure: Menuselect build configuration successfully completed

               .$$$$$$$$$$$$$$$=..      
            .$7$7..          .7$$7:.    
          .$$:.                 ,$7.7   
        .$7.     7$$$$           .$$77  
     ..$$.       $$$$$            .$$$7 
    ..7$   .?.   $$$$$   .?.       7$$$.
   $.$.   .$$$7. $$$$7 .7$$$.      .$$$.
 .777.   .$$$$$$77$$$77$$$$$7.      $$$,
 $$$~      .7$$$$$$$$$$$$$7.       .$$$.
.$$7          .7$$$$$$$7:          ?$$$.
$$$          ?7$$$$$$$$$$I        .$$$7 
$$$       .7$$$$$$$$$$$$$$$$      :$$$. 
$$$       $$$$$$7$$$$$$$$$$$$    .$$$.  
$$$        $$$   7$$$7  .$$$    .$$$.   
$$$$             $$$$7         .$$$.    
7$$$7            7$$$$        7$$$      
 $$$$$                        $$$       
  $$$$7.                       $$  (TM)     
   $$$$$$$.           .7$$$$$$  $$      
     $$$$$$$$$$$$7$$$$$$$$$.$$$$$$      
       $$$$$$$$$$$$$$$$.                

configure: Package configured for: 
configure: OS type  : linux-gnu
configure: Host CPU : x86_64
configure: build-cpu:vendor:os: x86_64 : pc : linux-gnu :
configure: host-cpu:vendor:os: x86_64 : pc : linux-gnu :
</pre>



<p>Next, you will need to select the modules that you want to install with Asterisk. You can select it using the following command:</p>



<pre class="wp-block-preformatted">make menuselect</pre>



<p>You can use the <strong>Arrow</strong> key to navigate and <strong>Enter</strong> key to select the modules.</p>



<p>Select and enables the <strong>Addons</strong> as shown below: <img loading="lazy" class="aligncenter size-medium wp-image-1430" src="https://linuxhostsupport.com/blog/wp-content/uploads/2021/05/how-to-install-asterisk-on-ubuntu-20.04-300x167.png" alt="how to install asterisk on ubuntu 20.04" width="300" height="167" srcset="https://linuxhostsupport.com/blog/wp-content/uploads/2021/05/how-to-install-asterisk-on-ubuntu-20.04-300x167.png 300w, https://linuxhostsupport.com/blog/wp-content/uploads/2021/05/how-to-install-asterisk-on-ubuntu-20.04-768x428.png 768w, https://linuxhostsupport.com/blog/wp-content/uploads/2021/05/how-to-install-asterisk-on-ubuntu-20.04.png 1024w" sizes="(max-width: 300px) 100vw, 300px" /></p>



<p>Next, enable the <strong>Core</strong> <strong>sound</strong> modules: <img loading="lazy" class="aligncenter size-medium wp-image-1431" src="https://linuxhostsupport.com/blog/wp-content/uploads/2021/05/set-up-asterisk-on-ubuntu-20.04-300x166.png" alt="set up asterisk on ubuntu 20.04" width="300" height="166" srcset="https://linuxhostsupport.com/blog/wp-content/uploads/2021/05/set-up-asterisk-on-ubuntu-20.04-300x166.png 300w, https://linuxhostsupport.com/blog/wp-content/uploads/2021/05/set-up-asterisk-on-ubuntu-20.04-768x425.png 768w, https://linuxhostsupport.com/blog/wp-content/uploads/2021/05/set-up-asterisk-on-ubuntu-20.04.png 1024w" sizes="(max-width: 300px) 100vw, 300px" /> Next, enable the additional <strong>MOH</strong> packages: <img loading="lazy" class="aligncenter size-medium wp-image-1432" src="https://linuxhostsupport.com/blog/wp-content/uploads/2021/05/how-to-set-up-asterisk-on-ubuntu-20.04-300x168.png" alt="how to set up asterisk on ubuntu 20.04" width="300" height="168" srcset="https://linuxhostsupport.com/blog/wp-content/uploads/2021/05/how-to-set-up-asterisk-on-ubuntu-20.04-300x168.png 300w, https://linuxhostsupport.com/blog/wp-content/uploads/2021/05/how-to-set-up-asterisk-on-ubuntu-20.04-768x429.png 768w, https://linuxhostsupport.com/blog/wp-content/uploads/2021/05/how-to-set-up-asterisk-on-ubuntu-20.04.png 1024w" sizes="(max-width: 300px) 100vw, 300px" /> Next, enable the <strong>Extra</strong> <strong>Sound</strong> Packages: <img loading="lazy" class="aligncenter size-medium wp-image-1433" src="https://linuxhostsupport.com/blog/wp-content/uploads/2021/05/setting-up-asterisk-on-ubuntu-20.04-300x166.png" alt="setting up asterisk on ubuntu 20.04" width="300" height="166" srcset="https://linuxhostsupport.com/blog/wp-content/uploads/2021/05/setting-up-asterisk-on-ubuntu-20.04-300x166.png 300w, https://linuxhostsupport.com/blog/wp-content/uploads/2021/05/setting-up-asterisk-on-ubuntu-20.04-768x426.png 768w, https://linuxhostsupport.com/blog/wp-content/uploads/2021/05/setting-up-asterisk-on-ubuntu-20.04.png 1024w" sizes="(max-width: 300px) 100vw, 300px" /></p>

<p>Now, click on the <strong>Save and Exit</strong> button.</p>



<p>Next, build the Asterisk using the following command:</p>



<pre class="wp-block-preformatted">make -j2</pre>



<p>Next, Asterisk and its modules using the following command:</p>



<pre class="wp-block-preformatted">make install</pre>



<p>You should get the following output:</p>



<pre class="wp-block-preformatted"> +---- Asterisk Installation Complete -------+
 +                                           +
 +    YOU MUST READ THE SECURITY DOCUMENT    +
 +                                           +
 + Asterisk has successfully been installed. +
 + If you would like to install the sample   +
 + configuration files (overwriting any      +
 + existing config files), run:              +
 +                                           +
 + For generic reference documentation:      +
 +    make samples                           +
 +                                           +
 + For a sample basic PBX:                   +
 +    make basic-pbx                         +
 +                                           +
 +                                           +
 +-----------------  or ---------------------+
 +                                           +
 + You can go ahead and install the asterisk +
 + program documentation now or later run:   +
 +                                           +
 +               make progdocs               +
 +                                           +
 + **Note** This requires that you have      +
 + doxygen installed on your local system    +
 +-------------------------------------------+
</pre>



<p>You can also install the documentation and basic PBX config files with the following command:</p>



<pre class="wp-block-preformatted">make samples
make basic-pbx</pre>



<p>Next, install the Asterisk init script with the following command:</p>



<pre class="wp-block-preformatted">make config</pre>



<p>Next, update the shared libraries using the following command:</p>



<pre class="wp-block-preformatted">ldconfig</pre>



<h2>Create Asterisk User</h2>



<p>It is always recommended to run Asterisk as a standalone user for security reasons.</p>



<p>First, create a new Asterisk user with the following command:</p>



<pre class="wp-block-preformatted">adduser --system --group --home /var/lib/asterisk --no-create-home --gecos "Asterisk PBX" asterisk</pre>



<p>Next, edit the Asterisk default configuration file and configure it to run as a asterisk user:</p>



<pre class="wp-block-preformatted">nano /etc/default/asterisk</pre>



<p>Uncomment the following lines:</p>



<pre class="wp-block-preformatted">AST_USER="asterisk"
AST_GROUP="asterisk"
</pre>



<p>Save and close the file then add the asterisk user to dialout and audio group:</p>



<pre class="wp-block-preformatted">usermod -a -G dialout,audio asterisk</pre>



<p>Next, set proper ownership and permissions of all Asterisk files and directories with the following command:</p>



<pre class="wp-block-preformatted">chown -R asterisk: /var/{lib,log,run,spool}/asterisk /usr/lib/asterisk /etc/asterisk
chmod -R 750 /var/{lib,log,run,spool}/asterisk /usr/lib/asterisk /etc/asterisk</pre>



<h2>Start and Verify Asterisk</h2>



<p>At this point, Asterisk is installed and configured. Now, you can start the Asterisk service using the following command:</p>



<pre class="wp-block-preformatted">systemctl start asterisk</pre>



<p>You can also enable the Asterisk service to start at system reboot with the following command:</p>



<pre class="wp-block-preformatted">systemctl enable asterisk</pre>



<p>To check the status of the Asterisk service, run the following command:</p>



<pre class="wp-block-preformatted">systemctl status asterisk</pre>



<p>You should get the following output:</p>



<pre class="wp-block-preformatted">● asterisk.service - LSB: Asterisk PBX
     Loaded: loaded (/etc/init.d/asterisk; generated)
     Active: active (running) since Sun 2021-05-16 12:24:29 UTC; 13s ago
       Docs: man:systemd-sysv-generator(8)
    Process: 60668 ExecStart=/etc/init.d/asterisk start (code=exited, status=0/SUCCESS)
      Tasks: 46 (limit: 4691)
     Memory: 34.7M
     CGroup: /system.slice/asterisk.service
             └─60685 /usr/sbin/asterisk -U asterisk -G asterisk

May 16 12:24:29 ubuntu2004 systemd[1]: Starting LSB: Asterisk PBX...
May 16 12:24:29 ubuntu2004 asterisk[60668]:  * Starting Asterisk PBX: asterisk
May 16 12:24:29 ubuntu2004 asterisk[60668]:    ...done.
May 16 12:24:29 ubuntu2004 systemd[1]: Started LSB: Asterisk PBX.
</pre>



<p>Now, connect to the Asterisk command line utility with the following command:</p>



<pre class="wp-block-preformatted">asterisk -vvvr</pre>



<p>Once connected, you should get the following output:</p>



<pre class="wp-block-preformatted">Asterisk GIT-18-78d7862463, Copyright (C) 1999 - 2021, Sangoma Technologies Corporation and others.
Created by Mark Spencer 
Asterisk comes with ABSOLUTELY NO WARRANTY; type 'core show warranty' for details.
This is free software, with components licensed under the GNU General Public
License version 2 and other licenses; you are welcome to redistribute it under
certain conditions. Type 'core show license' for details.
=========================================================================
Connected to Asterisk GIT-18-78d7862463 currently running on ubuntu2004 (pid = 60685)
ubuntu2004*CLI&gt; 
</pre>



<p>Congratulations! You have successfully installed and configured Asterisk server on Ubuntu 20.04 VPS.</p>



<p>Of course, you don’t have to install and set up Asterisk if you use one of our <a href="https://rosehosting.com/managed-vps-hosting.html">Managed VPS Hosting</a> services, in which case you can simply ask our expert Linux admins to install Asterisk on Ubuntu 20.04, for you. They are available 24×7 and will take care of your request immediately. If you&#8217;re looking to find something else, such as <a href="https://linuxhostsupport.com/blog/how-to-install-magento-2-on-ubuntu-20-04/">how to install Magento</a> or <a href="https://linuxhostsupport.com/blog/how-to-install-elasticsearch-on-ubuntu-20-04/">Elasticsearch</a> on Ubuntu 20.04, check out our blog.</p>
<p><img loading="lazy" class="size-full wp-image-1435 alignleft" src="https://linuxhostsupport.com/blog/wp-content/uploads/2021/05/install-asterisk-on-ubuntu-20.04.png" alt="install asterisk on ubuntu 20.04" width="200" height="200" srcset="https://linuxhostsupport.com/blog/wp-content/uploads/2021/05/install-asterisk-on-ubuntu-20.04.png 200w, https://linuxhostsupport.com/blog/wp-content/uploads/2021/05/install-asterisk-on-ubuntu-20.04-150x150.png 150w, https://linuxhostsupport.com/blog/wp-content/uploads/2021/05/install-asterisk-on-ubuntu-20.04-60x60.png 60w" sizes="(max-width: 200px) 100vw, 200px" /></p>



<p>If you liked this post on how to install Asterisk on Ubuntu 20.04, please share it with your friends on the social networks using the buttons on the left or simply leave a reply below. Thanks.</p><div class="linux-after-8th-paragraph" style="margin-left: auto; margin-right: auto; text-align: center; margin-top: 15px; margin-bottom: 15px; " id="linux-1475069069"><a href="https://www.rosehosting.com/managed-vps-hosting.html"><img loading="lazy" src="https://linuxhostsupport.com/blog/wp-content/uploads/2020/12/6437574992417416338.jpg" alt=""  srcset="https://linuxhostsupport.com/blog/wp-content/uploads/2020/12/6437574992417416338.jpg 728w, https://linuxhostsupport.com/blog/wp-content/uploads/2020/12/6437574992417416338-300x37.jpg 300w" sizes="(max-width: 728px) 100vw, 728px" width="728" height="90"  style="display: inline-block;" /></a></div>
<div class='heateor_sss_sharing_container heateor_sss_vertical_sharing heateor_sss_bottom_sharing' style='width:44px;left: -10px;top: 100px;-webkit-box-shadow:none;box-shadow:none;' heateor-sss-data-href='https://linuxhostsupport.com/blog/how-to-install-asterisk-on-ubuntu-20-04/'><ul class="heateor_sss_sharing_ul"><li class=""><i style="width:40px;height:40px;margin:0;" alt="Facebook" Title="Facebook" class="heateorSssSharing heateorSssFacebookBackground" onclick='heateorSssPopup("https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Flinuxhostsupport.com%2Fblog%2Fhow-to-install-asterisk-on-ubuntu-20-04%2F")'><ss style="display:block;" class="heateorSssSharingSvg heateorSssFacebookSvg"></ss></i></li><li class=""><i style="width:40px;height:40px;margin:0;" alt="Twitter" Title="Twitter" class="heateorSssSharing heateorSssTwitterBackground" onclick='heateorSssPopup("http://twitter.com/intent/tweet?text=How%20to%20Install%20Asterisk%20on%20Ubuntu%2020.04&url=https%3A%2F%2Flinuxhostsupport.com%2Fblog%2Fhow-to-install-asterisk-on-ubuntu-20-04%2F")'><ss style="display:block;" class="heateorSssSharingSvg heateorSssTwitterSvg"></ss></i></li><li class=""><i style="width:40px;height:40px;margin:0;" alt="Linkedin" Title="Linkedin" class="heateorSssSharing heateorSssLinkedinBackground" onclick='heateorSssPopup("http://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Flinuxhostsupport.com%2Fblog%2Fhow-to-install-asterisk-on-ubuntu-20-04%2F&title=How%20to%20Install%20Asterisk%20on%20Ubuntu%2020.04")'><ss style="display:block;" class="heateorSssSharingSvg heateorSssLinkedinSvg"></ss></i></li><li class=""><i style="width:40px;height:40px;margin:0;" alt="Pinterest" Title="Pinterest" class="heateorSssSharing heateorSssPinterestBackground" onclick="javascript:void( (function() {var e=document.createElement('script' );e.setAttribute('type','text/javascript' );e.setAttribute('charset','UTF-8' );e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);document.body.appendChild(e)})());"><ss style="display:block;" class="heateorSssSharingSvg heateorSssPinterestSvg"></ss></i></li><li class=""><i style="width:40px;height:40px;margin:0;" alt="Reddit" Title="Reddit" class="heateorSssSharing heateorSssRedditBackground" onclick='heateorSssPopup("http://reddit.com/submit?url=https%3A%2F%2Flinuxhostsupport.com%2Fblog%2Fhow-to-install-asterisk-on-ubuntu-20-04%2F&title=How%20to%20Install%20Asterisk%20on%20Ubuntu%2020.04")'><ss style="display:block;" class="heateorSssSharingSvg heateorSssRedditSvg"></ss></i></li><li class=""><i style="width:40px;height:40px;margin:0;" title="More" alt="More" class="heateorSssSharing heateorSssMoreBackground" onclick="heateorSssMoreSharingPopup(this, 'https://linuxhostsupport.com/blog/how-to-install-asterisk-on-ubuntu-20-04/', 'How%20to%20Install%20Asterisk%20on%20Ubuntu%2020.04', '' )" ><ss style="display:block" class="heateorSssSharingSvg heateorSssMoreSvg"></ss></i></li></ul><div class="heateorSssClear"></div></div>					</div><!-- .entry-content -->

		<footer class="entry-meta">

	    		      <!-- tags -->
	      <div class="tagcloud">

	          <a href="https://linuxhostsupport.com/blog/tag/asterisk/">asterisk</a> <a href="https://linuxhostsupport.com/blog/tag/linux/">linux</a> <a href="https://linuxhostsupport.com/blog/tag/ubuntu-20-04/">ubuntu 20.04</a> 
	      </div>
	      <!-- end tags -->
	      
		</footer><!-- .entry-meta -->
	</div>

	
</article><!-- #post-## -->

<div id="comments" class="comments-area">

		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/blog/how-to-install-asterisk-on-ubuntu-20-04/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://linuxhostsupport.com/blog/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea autocomplete="new-password"  id="ia2c8208eb"  name="ia2c8208eb"   cols="45" rows="8" maxlength="65525" required="required"></textarea><textarea id="comment" aria-hidden="true" name="comment" autocomplete="new-password" style="padding:0 !important;clip:rect(1px, 1px, 1px, 1px) !important;position:absolute !important;white-space:nowrap !important;height:1px !important;width:1px !important;overflow:hidden !important;" tabindex="-1"></textarea><script data-noptimize type="text/javascript">document.getElementById("comment").setAttribute( "id", "ab423c7c2d80bc462f78c03152c01243" );document.getElementById("ia2c8208eb").setAttribute( "id", "comment" );</script></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='1429' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><div class="g-recaptcha" data-sitekey="6LctHhYUAAAAAAtmsWiRup9UPstwWwM5LGgZO_Px" data-theme="standard"></div><script type="text/javascript"src="https://www.google.com/recaptcha/api.js?hl=en"></script>            <div id="recaptcha-submit-btn-area">&nbsp;</div>
            <noscript>
            <style type='text/css'>#submit {display:none;}</style>
            <input name="submit" type="submit" id="submit-alt" tabindex="6"
                value="Submit Comment"/> 
            </noscript></form>	</div><!-- #respond -->
	
</div><!-- #comments -->

	<nav class="navigation post-navigation" role="navigation" aria-label="Posts">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://linuxhostsupport.com/blog/how-to-create-a-new-user-and-grant-permissions-in-mysql/" rel="prev"><i class="fa fa-chevron-left"></i> <span class="post-title">How To Create a New User and Grant Permissions in MySQL</span></a></div></div>
	</nav>
		</main><!-- #main -->
	</div><!-- #primary -->

</div><!-- close .main-content-inner -->
	<div id="secondary" class="widget-area col-sm-12 col-md-4" role="complementary">
		<div class="well">
						<aside id="search-2" class="widget widget_search">
<form role="search" method="get" class="form-search" action="https://linuxhostsupport.com/blog/">
  <div class="input-group">
  	<label class="screen-reader-text" for="s">Search for:</label>
    <input type="text" class="form-control search-query" placeholder="Search&hellip;" value="" name="s" title="Search for:" />
    <span class="input-group-btn">
      <button type="submit" class="btn btn-default" name="submit" id="searchsubmit" value="Search"><span class="glyphicon glyphicon-search"></span></button>
    </span>
  </div>
</form></aside><aside class="widget linux-widget"><a href="https://www.rosehosting.com/managed-vps-hosting.html"><img src="https://linuxhostsupport.com/blog/wp-content/uploads/2020/12/922836_WebAds336x280V1_121820.png" alt=""  width="300" height="250"   /></a></aside><aside class="widget linux-widget"><a href="https://www.linuxhostsupport.com"><img src="https://linuxhostsupport.com/blog/wp-content/uploads/2020/12/300-250-max3.png" alt=""  width="300" height="250"   /></a></aside>
		<aside id="recent-posts-2" class="widget widget_recent_entries">
		<h3 class="widget-title">Recent Posts</h3>
		<ul>
											<li>
					<a href="https://linuxhostsupport.com/blog/how-to-install-asterisk-on-ubuntu-20-04/" aria-current="page">How to Install Asterisk on Ubuntu 20.04</a>
									</li>
											<li>
					<a href="https://linuxhostsupport.com/blog/how-to-create-a-new-user-and-grant-permissions-in-mysql/">How To Create a New User and Grant Permissions in MySQL</a>
									</li>
											<li>
					<a href="https://linuxhostsupport.com/blog/how-to-install-thelia-on-ubuntu-18-04/">How to Install Thelia on Ubuntu 18.04</a>
									</li>
											<li>
					<a href="https://linuxhostsupport.com/blog/how-to-install-laravel-on-ubuntu-18-04/">How to Install Laravel on Ubuntu 18.04</a>
									</li>
											<li>
					<a href="https://linuxhostsupport.com/blog/how-to-install-mahara-on-ubuntu-20-04/">How to Install Mahara on Ubuntu 20.04</a>
									</li>
					</ul>

		</aside><aside id="categories-2" class="widget widget_categories"><h3 class="widget-title">Categories</h3>
			<ul>
					<li class="cat-item cat-item-5"><a href="https://linuxhostsupport.com/blog/category/guides/">Guides</a>
</li>
	<li class="cat-item cat-item-179"><a href="https://linuxhostsupport.com/blog/category/laravel/">Laravel</a>
</li>
	<li class="cat-item cat-item-1"><a href="https://linuxhostsupport.com/blog/category/miscellaneous/">Miscellaneous</a>
</li>
	<li class="cat-item cat-item-2"><a href="https://linuxhostsupport.com/blog/category/tutorials/">Tutorials</a>
</li>
	<li class="cat-item cat-item-182"><a href="https://linuxhostsupport.com/blog/category/ubuntu/">Ubuntu</a>
</li>
	<li class="cat-item cat-item-181"><a href="https://linuxhostsupport.com/blog/category/ubuntu-18-04/">Ubuntu 18.04</a>
</li>
			</ul>

			</aside>		</div>
	</div><!-- #secondary -->
		</div><!-- close .row -->
	</div><!-- close .container -->
</div><!-- close .site-content -->


    <div class="main-footer section-padding">
      <footer class="footer-nav">
        <div class="container">
          <div class="row">
            <div class="col-xs-12 col-sm-6 col-md-3 link">
              <h4>Company</h4>
              <ul class="list-unstyled">
                <li><a href="https://linuxhostsupport.com/about.html">About Us</a></li>
                <li><a href="https://linuxhostsupport.com/contact.html">Contact Us</a></li>
                <li><a href="https://linuxhostsupport.com/blog/">Blog</a></li>
              </ul>
            </div>
            <div class="col-xs-12 col-sm-6 col-md-3 link">
              <h4>Services</h4>
              <ul class="list-unstyled">
                <li><a href="https://linuxhostsupport.com/monthly-server-management.html">Monthly Server Management</a></li>
                <li><a href="https://linuxhostsupport.com/per-incident-support.html">Per Incident Server Support</a></li>
                <li><a href="https://linuxhostsupport.com/outsourced-hosting-support.html">Outsourced Hosting Support</a></li>
				<li><a href="https://linuxhostsupport.com/other-management-and-support-services.html">Other Management & Support Services</a></li>
              </ul>
            </div>
            <div class="col-xs-12 col-sm-6 col-md-3 link">
              <h4>Support</h4>
              <ul class="list-unstyled">
                <li><a href="https://my.linuxhostsupport.com/index.php?/clientarea/">Client Area</a></li>
              </ul>
            </div>
            <div class="col-xs-12 col-sm-6 col-md-3 social">
              <h4>Follow us</h4>
              <ul class="list-unstyled">
                <li>
                  <a href="https://www.facebook.com/linuxhostsupport" target="_blank">
                    <span class="icon">
                      <svg viewBox="0 0 32 32" xmlns="http://www.w3.org/2000/svg" style="fill:currentcolor">
                        <path d="M8 12 L13 12 L13 8 C13 2 17 1 24 2 L24 7 C20 7 19 7 19 10 L19 12 L24 12 L23 18 L19 18 L19 30 L13 30 L13 18 L8 18 z"></path>
                      </svg>
                    </span>
                    <span class="text">Facebook</span>
                  </a>
                </li>
                <li>
                  <a href="https://twitter.com/lnxhostsupport" target="_blank">
                    <span class="icon">
                      <svg viewBox="0 0 32 32" xmlns="http://www.w3.org/2000/svg" style="fill:currentcolor">
                        <path d="M2 4 C6 8 10 12 15 11 A6 6 0 0 1 22 4 A6 6 0 0 1 26 6 A8 8 0 0 0 31 4 A8 8 0 0 1 28 8 A8 8 0 0 0 32 7 A8 8 0 0 1 28 11 A18 18 0 0 1 10 30 A18 18 0 0 1 0 27 A12 12 0 0 0 8 24 A8 8 0 0 1 3 20 A8 8 0 0 0 6 19.5 A8 8 0 0 1 0 12 A8 8 0 0 0 3 13 A8 8 0 0 1 2 4"/>
                      </svg>
                    </span>
                    <span class="text">Twitter</span>
                  </a>
                </li>
                <li>
                  <a href="https://www.linkedin.com/company/linuxhostsupport.com" target="_blank">
                    <span class="icon">
                      <svg fill="currentColor" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 16 16">
                        <path d="M13.632 13.635h-2.37V9.922c0-.886-.018-2.025-1.234-2.025-1.235 0-1.424.964-1.424 1.96v3.778h-2.37V6H8.51V7.04h.03c.318-.6 1.092-1.233 2.247-1.233 2.4 0 2.845 1.58 2.845 3.637v4.188zM3.558 4.955c-.762 0-1.376-.617-1.376-1.377 0-.758.614-1.375 1.376-1.375.76 0 1.376.617 1.376 1.375 0 .76-.617 1.377-1.376 1.377zm1.188 8.68H2.37V6h2.376v7.635zM14.816 0H1.18C.528 0 0 .516 0 1.153v13.694C0 15.484.528 16 1.18 16h13.635c.652 0 1.185-.516 1.185-1.153V1.153C16 .516 15.467 0 14.815 0z" fill-rule="nonzero"/>
                      </svg>
                    </span>
                    <span class="text">LinkedIn</span>
                  </a>
                </li>
              </ul>
            </div>
          </div>
        </div>
      </footer>
      <footer class="footer-bottom">
        <div class="container">
          <div class="row">

            <div class="col-md-6 col-xs-12 link">
              <ul class="list-inline">
                <li><a href="https://linuxhostsupport.com/tos.html">Terms of Service</a></li>
                <li><a href="https://linuxhostsupport.com/privacy.html">Privacy Policy</a></li>
              </ul>
            </div>
            <div class="col-md-6 col-xs-12">
              <p class="footer-copyright link">
                Copyright 2021 &copy; <a href="http://www.rosewebservices.com/">Rose Web Services LLC</a>.
              </p>
            </div>
          </div>
        </div>
      </footer>
    </div>


</div><!-- #page -->


<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-TBQFNCW');</script>
<!-- End Google Tag Manager -->

<!-- livezilla.net code
<script type="text/javascript" id="aff1f81b02f303eea5f87a3a065f153a" src="https://linuxhostsupport.com/chat//script.php?id=aff1f81b02f303eea5f87a3a065f153a"></script>
http://www.livezilla.net -->

  <script type="text/javascript">
    jQuery( document ).ready( function( $ ){
      if ( $( window ).width() >= 767 ){
        $( '.navbar-nav > li.menu-item > a' ).click( function(){
            if( $( this ).attr('target') !== '_blank' ){
                window.location = $( this ).attr( 'href' );
            }
        });
      }
    });
  </script>
            <script type="text/javascript">
            var sub = document.getElementById('submit');
            document.getElementById('recaptcha-submit-btn-area').appendChild (sub);
            document.getElementById('submit').tabIndex = 6;
            if ( typeof _recaptcha_wordpress_savedcomment != 'undefined') {
                document.getElementById('comment').value = 
                    _recaptcha_wordpress_savedcomment;
            }
            </script><script type='text/javascript' src='https://linuxhostsupport.com/blog/wp-content/themes/lhs/inc/js/functions.min.js?ver=20180519' id='sparkling-functions-js'></script>
<script type='text/javascript' src='https://linuxhostsupport.com/blog/wp-content/themes/lhs/inc/js/skip-link-focus-fix.js?ver=20140222' id='sparkling-skip-link-focus-fix-js'></script>
<script type='text/javascript' src='https://linuxhostsupport.com/blog/wp-includes/js/comment-reply.min.js?ver=5.7.2' id='comment-reply-js'></script>
<script type='text/javascript' id='heateor_sss_sharing_js-js-before'>
function heateorSssLoadEvent(e) {var t=window.onload;if (typeof window.onload!="function") {window.onload=e}else{window.onload=function() {t();e()}}};	var heateorSssSharingAjaxUrl = 'https://linuxhostsupport.com/blog/wp-admin/admin-ajax.php', heateorSssCloseIconPath = 'https://linuxhostsupport.com/blog/wp-content/plugins/sassy-social-share/public/../images/close.png', heateorSssPluginIconPath = 'https://linuxhostsupport.com/blog/wp-content/plugins/sassy-social-share/public/../images/logo.png', heateorSssHorizontalSharingCountEnable = 0, heateorSssVerticalSharingCountEnable = 0, heateorSssSharingOffset = -10; var heateorSssMobileStickySharingEnabled = 1;var heateorSssCopyLinkMessage = "Link copied.";var heateorSssUrlCountFetched = [], heateorSssSharesText = 'Shares', heateorSssShareText = 'Share';function heateorSssPopup(e) {window.open(e,"popUpWindow","height=400,width=600,left=400,top=100,resizable,scrollbars,toolbar=0,personalbar=0,menubar=no,location=no,directories=no,status")};var heateorSssWhatsappShareAPI = "web";
</script>
<script type='text/javascript' src='https://linuxhostsupport.com/blog/wp-content/plugins/sassy-social-share/public/js/sassy-social-share-public.js?ver=3.3.21' id='heateor_sss_sharing_js-js'></script>
<script type='text/javascript' src='https://linuxhostsupport.com/blog/wp-includes/js/wp-embed.min.js?ver=5.7.2' id='wp-embed-js'></script>

<!-- This site is optimized with Phil Singleton's WP SEO Structured Data Plugin v2.6.17.1 - https://kcseopro.com/wordpress-seo-structured-data-schema-plugin/ -->

<!-- / WP SEO Structured Data Plugin. -->


</body>
</html>

<!--
Performance optimized by W3 Total Cache. Learn more: https://www.boldgrid.com/w3-total-cache/

Object Caching 65/136 objects using disk
Page Caching using disk: enhanced (SSL caching disabled) 

Served from: linuxhostsupport.com @ 2021-07-04 03:29:22 by W3 Total Cache
-->